FRANKLYWNOW - WorldNow Installation Information

WorldNow Installation Information

Introduction

This site has been set up to help configure your system to work effectively with the WorldNow Producer. For all installations steps, you must be logged on as yourself, whether or not you are an Administrator. If you are not an Administrator, please contact your Network Administrator. 

1. System Requirements

  • On Windows 2000, XP and Vista: Internet Explorer 6/7/8 and Firefox 3+
  • On Mac OS X: Firefox 3+

Note:  If you are using Firefox, you do not need to follow the instructions to configure security settings.

2. Trusted Sites Configuration

Security settings must be set within Internet Explorer.

  • First, open Internet Explorer and click the "Tools" menu, followed by "Internet Options".

  • In the Internet Options dialog box click the "Security" tab. Select "Trusted sites"

  • Under the "Security level for this zone" select "Custom Level". Your Internet Options dialog box should look like this:

Powered by Frankly
All content &copy; Copyright 2000 - 2019. All Rights Reserved. <BR>For more information on this site, please read our <a href="//wnow.worldnow.com/story/18990/this-web-sites-privacy-policy" >Privacy Policies </a>, and <A HREF="//wnow.worldnow.com/story/18991/this-sites-terms-of-service">Terms of Service</A>.